Page 1 of 1

Tutorial to create a desktop icon for your game

PostPosted: Tue Apr 29, 2008 7:01 pm
by GM-Support
-------------------------------------------------------------------------
TUTORIAL TO MODIFY THE INSTALLER SO THAT IT CREATES A DESKTOP ICON
-------------------------------------------------------------------------


1. When you are ready to compile your project, click "Distribute (create exe)" and then click "Start Distribution".

2. Click OK until you get the following message: "Adventure Maker is now ready to create a setup file for your project. The process may take a few minutes."

3. For the moment, do NOT click OK. With Notepad, edit the file "PROJECTNAME.ISS" that is located inside the Adventure Maker folder (i.e. the folder in which you have installed Adventure Maker).
NOTE: The ISS file is located in C:\Users\.....\Documents\Adventure Maker v4.7 for Adventure Maker versions 4.7.* and later.

4. You will notice that at the very end of the file there is an "Icons" section that contains the following code:

Code: Select all
[Icons]
Name: "{group}\PROJECT_TITLE"; Filename: "{app}\PROJECT_TITLE.exe"; WorkingDir: "{app}"


(where PROJECT_TITLE depends on what you have entered in the Project Properties).

Duplicate the line that starts with "Name:" and change the word "group" into "userdesktop", so that at the end the code looks like that:

Code: Select all
[Icons]
Name: "{group}\PROJECT_TITLE"; Filename: "{app}\PROJECT_TITLE.exe"; WorkingDir: "{app}"
Name: "{userdesktop}\PROJECT_TITLE"; Filename: "{app}\PROJECT_TITLE.exe"; WorkingDir: "{app}"


(the only difference between the first line and the second one is that the word "group" has been replaced with "userdesktop")

5. Now save and close the file. Go back to Adventure Maker and click OK to resume the creation of the setup file.



Regards,
GM-Support

PostPosted: Wed Apr 30, 2008 6:09 pm
by Lyberodoggy
I saw this yesterday, but right when I was going to answer, I run outta time... Anyway, Thanks GM, this tut is wonderful

PostPosted: Wed Apr 30, 2008 7:47 pm
by Candle
Really need to upgrade to a new installer or maybe go the single file for the exe to run the game.

PostPosted: Thu May 01, 2008 11:54 am
by Ron_Emad2
Ohhhhhhhhhh
thanks
it work fine
i test it on my project
very veryvery very gooooooood :D

PostPosted: Sun Jan 11, 2009 10:10 pm
by cpkspikyhair
Please someone sticky this!!! I have needed to use it many times, it would be great to not have to go far :D :D :D

PostPosted: Mon Jan 12, 2009 12:08 am
by Zenoc2
I know nothing about coding, and thus try to avoid it. Still, desktop icons are necessities. Now how do you change what file it uses for the icon picture?

PostPosted: Mon Jan 12, 2009 1:24 am
by reneuend
Just change the 'ico' file to the correct filename in the first and second line.

example
change chicken.ico to the new filename

Name: "{group}\Escape From Hick Chick Run"; Filename: "{app}\Escape From Hick Chick Run.exe"; IconFilename: "{app}\chicken.ico"; WorkingDir: "{app}"


Name: "{userdesktop}\Escape From Hick Chick Run"; Filename: "{app}\Escape From Hick Chick Run.exe"; IconFilename: "{app}\chicken.ico"; WorkingDir: "{app}"

PostPosted: Mon Jan 12, 2009 1:32 am
by Zenoc2
Great. I'll try to remember that, but I'll probably need to refer to this a few more times, so I second the request for a sticky.

PostPosted: Fri Apr 17, 2009 3:29 pm
by Kat12
Thank you! I was so happy to be able to include a desktop icon because without it, my friends couldn't find the game on their computer, lol.
Kathy

:D

PostPosted: Fri Apr 17, 2009 4:07 pm
by ZeornWarlock
For some reason I cannot get this to work! :(

Do I need to have the icon in Icons and Cursors or in Software Icons or both? At the moment it is in the Icons and Cursors.

This is the code I have in the ISS file...

Code: Select all
Name: "{group}\ZW Mini Drawing Tutorial no 01"; Filename: "{app}\ZW Mini Drawing Tutorial no 01.exe";IconFilename: "{app}\ZW_Tut01_Icon.ico"; WorkingDir: "{app}"

Name: "{userdesktop}\ZW Mini Drawing Tutorial no 01"; Filename: "{app}\ZW Mini Drawing Tutorial no 01.exe";IconFilename: "{app}\ZW_Tut01_Icon.ico"; WorkingDir: "{app}"


Any help would be appreciated. ;)

ZW.

PostPosted: Fri Apr 17, 2009 6:57 pm
by mercedes
Do you have both Z ?.

If so, You only need the one code in there..replacing 'group' with 'userdesktop'

You would need just the bottom one u have..:)

Code: Select all
[Icons]
Name: "{userdesktop}\ZW Mini Drawing Tutorial no 01"; Filename: "{app}\ZW Mini Drawing Tutorial no 01.exe"; IconFilename:"{app}\ZW_Tut01_Icon.ico"; WorkingDir: "{app}"


GM put's it like this...I think this way is if u store the actual icon on the desktop..the one u will use..and it is named already.?

Code: Select all
[Icons]
Name: "{userdesktop}\ZW Mini Drawing Tutorial no 01"; Filename: "{app}\ZW Mini Drawing Tutorial no 01.exe"; WorkingDir: "{app}"

PostPosted: Mon Apr 20, 2009 4:45 am
by ZeornWarlock
mercedes,

I still cannot make it work! I have a mini drawing tutorial done; however, I do not want to patch it just for a desktop icon. :x

ZW.

PostPosted: Tue Apr 21, 2009 6:56 am
by mercedes
EDIT...I got it to work..Zed..I'll reply to your email...:haha:..funny..This was new to me..so it was something else I installed before...:?

***********************************

I'm adding this..in case someone else couldn't' get it to work~

First of all, You have to install game to see the desktop icon :lol: I was expecting it to change after creating it...:P


It was in the Directory of Software Icons, in Manage Resources..I put it there first.

In Distribution options, for it to appear automatically,[in notepad] I put in the General Tab, the start menu/programs icon--I put the one i wanted..It will be in the directory software icons

Then once u open up notepad, it will all be there for u, You simply just duplicate the line..and put in [userdesktop]

Install game and voila, u will see the desktop icon..~

Doing it this way will insure you have your icon set up, If not, u end up with default one..If you go through Distribution Options..It will automatically add your desktop icon. :D Or you can type in what Reneuend has up top as well, in his post, for its the same lines~

Peace

PostPosted: Mon Apr 27, 2009 8:18 pm
by ZeornWarlock
Thanks, mercedes! Because of you, I can finally complete some of my projects. :)

ZW.

PostPosted: Sun Jun 21, 2009 7:55 am
by Lazypookzz
I can't find a *.ISS file :oops: ??!!

PostPosted: Sun Jun 21, 2009 8:11 am
by mercedes
Here is what it should look like..when u do it..
Just when u compile the game..right after it says;

AdventureMaker is now ready to set up the file..DON'T hit OK- just yet..

Go to Distribution Options and under General TAB--pick your desktop icon..Then;

Go through Windows Explorer>>
Browse to your C drive>>>Program files>>>Adventure Maker..

Right where u see all that is within Adventure Maker..
You will see a file named after your game, .iss file..You may have to point/hover over it..to see it..~
Here is an attachment; The name of my project is called TEXTproject..It will be a NOTEpad file.

Let me know if this helps..:D

PostPosted: Sun Jun 21, 2009 9:18 am
by Lazypookzz
@ MercedezThankzzzzzzzzzz!! :D


What I did wrong
- I never picked the icon
- I knew where to look, but I looked at the wrong time :oops:

Great, it works! :mrgreen:

PostPosted: Mon Aug 15, 2011 1:45 am
by Vengeance66
When I tried to save the changes Projectname.iss file, it says Access Denied!...

:(

Every error happens to me...

PostPosted: Mon Aug 15, 2011 5:11 am
by reneuend
You must be using Vista or Win7. check the permissions on the file and make sure its not read-only. I ran into this issue in the past too.

Right-click on the file and click on properties to check for this attribute.

PostPosted: Mon Aug 15, 2011 11:08 am
by Vengeance66
reneuend wrote:You must be using Vista or Win7. check the permissions on the file and make sure its not read-only. I ran into this issue in the past too.

Right-click on the file and click on properties to check for this attribute.


I checked for it and it's not read only. Maybe I have to run it as administrator...

I'm using Win 7

PostPosted: Tue Aug 16, 2011 3:57 am
by reneuend
I'm not sure what the fix is. Maybe try running AM as administrator and see if that works.

PostPosted: Tue Aug 16, 2011 10:17 am
by Vengeance66
It was the problem with the access. Every time I have to put Full Access to that file for my user... :) :) :)

Re: Tutorial to create a desktop icon for your game

PostPosted: Sun Aug 04, 2013 1:16 pm
by Vengeance66
I'm on 4.7.1 and I cannot find the same as it was before...

Any solutions?

Thank you!

Re: Tutorial to create a desktop icon for your game

PostPosted: Sun Aug 04, 2013 4:40 pm
by reneuend
Hi V66.

Please contact me by PM or email and I will help you. If its something we should post, we can do that after we resolve your issue.

Re: Tutorial to create a desktop icon for your game

PostPosted: Sun Aug 04, 2013 11:12 pm
by Vengeance66
So, I guess the first post needs to be updated.

It's not in AM folder where it's installed, it's in the AM folder in My Documents. Mine was: C:\Users\.....\Documents\Adventure Maker v4.7

Hope this will be of help to someone :-)