Page 1 of 1

Cubic Pano errors

PostPosted: Sun May 30, 2010 7:14 am
by Grumpydlw
I'm having trouble inserting a video in the cubic pano plugin.
I get automation scripting error.
Are there limits as to the type of video? like only simple avi not Xvid?
I can't get an uncompressed AVI or an Xvid avi to run in the cubic pan.
I'm running XP with SP3 and all current updates and drivers.
Any ideas?
Thanks
Grumpydlw

PostPosted: Sun May 30, 2010 11:38 am
by Mystery
How did you try to embed the video? In a hotspot?
According to the description it should work in hotspots.

You can animate the panoramas by embedding looping videos (to do so, create a hotspot, and choose "looping video" under the "Appearance" section of the Hotspot Properties). You can make such videos appear and disappear according to the values of the variables.

cubic pano error

PostPosted: Sun May 30, 2010 3:34 pm
by Grumpydlw
Hi Mystery,
None of the prescribed methods worked.
When I tried the hotspot method the program locked up.
When I gave it the coordinates it says they are out of range
When I tried the play a video in the Cubic pan it showed the first (or last) frame only and did nothing for the duration of the video.
I'm going to try again with all possibilities today and will post screen message results.
If I still get the errors I'll break my scene down into a single frame and video and send them to you.
Thanks for your help.
Grumpydlw

PostPosted: Sun May 30, 2010 3:37 pm
by Mystery
I see...

I don't have much experience with the Cubic Panorama, but it's strange that none of the methods worked, because at least the hotspot method should work.

Yes, if you can't make it work, send me the AM project folder with 1 panoramic scene and the video in a hotspot. I'll be interested to try it out, and maybe can figure out what's wrong. I'll be away for a few hours, but I can look at it when I come home.


EDIT
Thanks for sending me the AM project folder.
On my laptop, it works perfectly :)
Do you still get the error on your computer?

Cubic Pano errors

PostPosted: Mon May 31, 2010 3:19 am
by Grumpydlw
Hi Everybody.
I'm still getting an error message when I try to run a video in a hotspot in a cubic panorama.
The error message is attached.
I have uninstalled and re installed AM and the plug in.
I'm running XP with SP3
Nvidia 9500 video card
DirectX 9c
The pano works fine but when I trigger the hotspot to play the video I get an all motion stop (freeze) for the duration of the video then this error message.
Mystery says it worked fine on her computer? Thank you Mystery.
Any ideas???

PostPosted: Mon May 31, 2010 3:36 am
by Mystery
Yes, it does work for me smoothly, no problems at all. :)

Okay, now let's see.
You have already reinstalled AM and the plugin.
But: AM uses your Windows Media Player (plus codecs if you have compressed your video). So this could also be a source of your issues.

Do you have any problems to open and play the video file in Windows Media Player?

Additionally, it might be helpful if you could get the event log concerning this issue.
In case you don't know how to get it, check here:
http://support.microsoft.com/kb/308427

cubic pano error

PostPosted: Mon May 31, 2010 3:55 am
by Grumpydlw
Thank you Mystery,
I'll check the log and get back.
The video works fine in Media Player.
Grumpydlw

PostPosted: Mon May 31, 2010 10:26 am
by Mystery
Okay, I'm curious to see the error report(s).

Even though you experience no problems in Windows Media Player if you play the file directly, it could be still the source.
Can you tell me which version of it you are using? And if you have attempted to update it (if a newer version is available)?

Another thing that you could try is to play the video file in a test project without the Cubic Panorama plugin, just a plain screen with a hotspot. Do you get the same error?

(I also assume that you weren't listening to other music on Windows Media Player while trying your game)

cubic pano error

PostPosted: Mon May 31, 2010 5:13 pm
by Grumpydlw
OK this is cute???
I looked at the viewer and even if t he last thing I did was get an error.
It is not being reported in the event log.
The video works in a non-pano background.
I do have the sound of the flush playing from the hotspot.
The wav file is NOT part of the AVI.

I do find that under system there is a log entry that says something about errors that makes reference to a Beta of Office 2010. There is an entry for that every couple minuntes. Not all errors.
I've had problems with my computer losing focus on the open window ever since I installed this Beta. I'm going to remove it as soon as I can export my email.

I'll let you know.

PostPosted: Mon May 31, 2010 5:20 pm
by Mystery
And there is no event report in the "Applications" area either (I understood that you have looked in the "System" related part)?

Also, is there an update available for Windows Media Player, or do you have the latest version?


EDIT
Can you also tell me which NVIDIA driver version you have if deinstalling that beta program doesn't resolve it?
I have heard that a new driver version is causing huge issues, and has been removed from the NVIDIA site while it gets fixed.

cubic pano error

PostPosted: Mon May 31, 2010 6:34 pm
by Grumpydlw
I'm back.
I looked in all of them.
Also Keep all updates current at all times.
I am running "the most recent version of WinMedia and all it's components"
I opened the test project.
Ran the "game" opened the lid, pressed the button.
Got the error. Said OK closed the application.
Exported the Log Files.
I got the error at 10:22AM 5/30/10 for reference.
I hope you can find something I don't recognize.
Thank you for your help. I'm really stumped.
Grumpydlw

PostPosted: Mon May 31, 2010 6:39 pm
by Mystery
Just to make sure: you mean 10:22AM 5/30/10 or 10:22AM 5/31/10 ?

If you mean May 31, then the only logs for that time come from the Security section.
Can you go for each of the 6 incidents that occurred on 10:22 AM on the details tab, and copy-paste the texts from there?
This only if you mean May 31.

Cubic Pano errors

PostPosted: Mon May 31, 2010 7:36 pm
by Grumpydlw
Another day already?
Where does the time go.
YES the 31st.

Here are screen shots of the 6
I really appreciate this and hope it helps.
Grumpydlw

Cubic Pano errors

PostPosted: Mon May 31, 2010 7:39 pm
by Grumpydlw
Here's the 6th one

PostPosted: Mon May 31, 2010 8:04 pm
by Mystery
Yeah, time flies indeed :lol:

Okay, those successful audit messages are infos about user logon, network logon etc.
Did you start your PC/logged into your account at that time, just right before trying your game and getting the error message?

Cubic Pano errors

PostPosted: Mon May 31, 2010 8:17 pm
by Grumpydlw
No I'd been on for a while.
One of the logins was my wifes computer?
I don't know why, we aren't sharing anything except my printer which she hasn't used this morning. She was also already logged on so I don't know why that was happening right then.
I turned off the sound file and I still get the error.
I get the error right after the sound starts but it does play all the way through. just no video.
When I open the frame to edit, the video does play one time then stops.
Thanks

PostPosted: Mon May 31, 2010 8:27 pm
by Mystery
Yes, I've seen the reference to the other machine...

Hmmm, okay, I did some reading, but to be sure that these log reports are indeed somehow connected to the issues when you're trying to play your game, please note down the time, then play your game, and see if you get the same content in the security logs that match the time.

So basically I would like to see if the time-related coincidence of the game error message and the security log contents can be reproduced.

Cubic Pano errors

PostPosted: Mon May 31, 2010 9:52 pm
by Grumpydlw
Hi,
The entries occur everytime I do anything.
They are recording everything I do.
The time stamp seems to indicate the time I am changing active program windows. Like when I go from AM to the desktop or start button or open the service manager. etc.
I do note that I am being given "special" permission to do some things tho I don't know why.
I am the administrator and onlly user of this machine.

Does this help?

PostPosted: Mon May 31, 2010 9:59 pm
by Mystery
Well, I'm specifically interested if the log reports are repeating themselves at the time when you get that error message in your game.

Those audit reports refer to user login, network login, but also to the starting of a service for example. So if we find that at the time when you get that error message, there is always the same service that tries to start for example, we might be onto something.

It appears that when you try to play the video in the pano, your pc gets overwhelmed by something, just don't know what (it could be a Windows service, memory issues, overheating, graphic card issue etc.). I'm trying to narrow it down.

(This also upon a finding here: http://social.answers.microsoft.com/For ... 64578ddec1
Although it's a different issue and another OS, it still seems to have similarities with your problems - not sure how much though.)

Cubic Pano errors

PostPosted: Tue Jun 01, 2010 8:07 pm
by Grumpydlw
HI,
I tried the suggestions in the article and while it did improve some performance issues I was having it didn't help with the Pano Error.

Wow. what a puzzler.
Thank you,
Grumpydlw

PostPosted: Tue Jun 01, 2010 8:40 pm
by Mystery
Yeah, you name it, a difficult puzzle :shock:
All we know is that playing the video in a pano scene makes your pc faint - sort of...


Okay, how about opening Task Manager (alt+ctrl+del keys) and setting it so that the list shows processes with high CPU usage at the top.
Then try the pano scene, and if possible check during the error issues, if any process hits 100%.

And also check if any logs (application, system, security etc.) appear concerning this time.

Re: Cubic Pano errors

PostPosted: Thu Oct 22, 2015 4:57 pm
by Vengeance66
Hi,

I didn't want to open new topic to ask why am I getting this error while activating only Cubic Panorama. I have the 1.2 version and I got registration details (I forgot how to register, but that's for later).

Here are the screenshots:

http://imgur.com/M0RhjU8

http://imgur.com/r8pxqQM

After clicking OK the frame starts, but no panoramic view, only static.

I have AM Panorama installed with AM and I am on Windows 10. I've never seen this problem before and I've used Cubic Panorama earlier.

Re: Cubic Pano errors

PostPosted: Thu Oct 22, 2015 10:57 pm
by reneuend
Hi V66!

Perhaps the following will help:

Sometimes the OCX file needs to be unregistered and then registered.

Run the command prompt as an administrator
Then edit and enter the following:

%systemroot%\SysWoW64\regsvr32.exe "C:\Users\V66\Documents\Adventure Maker v4.7\Shared\Plugins\<name of plugin>.ocx"

More information at https://support.microsoft.com/en-us/kb/249873

Please report back and let us know if this helps!

Re: Cubic Pano errors

PostPosted: Thu Oct 22, 2015 11:26 pm
by Vengeance66
Thank you very much Reneuend!

Worked like magic! Didn't know this and I've never done it before. :D

Re: Cubic Pano errors

PostPosted: Fri Oct 23, 2015 1:45 am
by reneuend
All I ask in return is that we build a game together next year! :mrgreen:

Re: Cubic Pano errors

PostPosted: Fri Oct 23, 2015 6:12 am
by Candle

Re: Cubic Pano errors

PostPosted: Fri Oct 23, 2015 10:28 am
by Vengeance66
reneuend wrote:All I ask in return is that we build a game together next year! :mrgreen:


Not a problem! :mrgreen:

Thanks Candle. :D