CUBIC PANORAMA PLUGIN released! (beta)

This forum is meant for posting anything related to Adventure Maker that doesn't fit in the other forums.Please post technical questions in the Technical Support Forum!

Moderators: time-killer-games, Vengeance66, Candle, reneuend, GM-Support

Postby Candle » Fri Apr 25, 2008 10:37 pm

this is a new card i just got last week.
Please don't PM me questions, ask here in the forums!
``````````````
Between grand theft and a legal fee, there only stands a law degree.
User avatar
Candle
Administrator
 
Posts: 3055
Joined: Sat Feb 07, 2004 2:21 am
Location: Rudy's Bar

Postby Von Knudenberg » Fri Apr 25, 2008 10:50 pm

It seems that sunday came soon. After 250 km driving these lousy asphalts my destination contact phoned about really severe vomiting disease. Since I have to be on flight on monday, I decided to turn back and drive home "sweet" home (first time in F-18C Hornet and I'm quite sure that I'm going to vomit even without any certain disease :).

And now cut the bullexcrement and back to topic!

I tested your most new ocx. I had same kind of results like with 1.5 beta. Starting face is okay (with green triangle when turning from right). All the other faces turns to green, just like they did with 1.5.

But don't give up! Cut those big balls from these evil spirited new graphic cards. I'm sure you will do that eventually.

-Pete
Von Knudenberg
Member
 
Posts: 54
Joined: Mon Jan 28, 2008 11:20 am
Location: Finland

Postby Imari » Sat Apr 26, 2008 2:31 am

Hi GM, I just got home and have tested your two new versions on my 8800 GTX. I had the same problems with the green triangles forming and the green faces as the others did with the first version.

With the pink and green version (oh my eyes! :shock: :P ), I think that I may have had a slightly different effect. I see the pink faces and the green seams/edges at the start.

1. If I place my cursor mid-way down one of the corner seams/edges and drag my cursor straight down, I get a green triangle, pointing left and forming always to the left side, not the right. If I continue dragging down the corner seam until I pan onto the bottom face of the cube, I can still see the triangle on the left "wall" and the floor is divided in half on the diagonal. The left half of the floor is green.

2. If I drag my cursor upwards from the mid-way point on the seam instead of down, the triangle does not form, however, soon after my cursor crosses the corner onto the top face of the cube, the whole top face of the cube goes green.

3. Back to the midpoint of the corner seam... If I pan left, I first get the green triangle pointing left towards the center of the face. Then the face is entirely green for about 20 degrees of movement, and then the pink face "renders".

4. From the midpoint of the face, I can move up or down to the upper and lower edges just fine, but if I pan more than about 20 degrees left or right of center, the whole face goes green again.

Hope this helps, and thanks for slugging away at this again.

[P. S. to Pete - Yipes, good luck on that flight! ]
Last edited by Imari on Sat Apr 26, 2008 1:25 pm, edited 1 time in total.
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby Genomax » Sat Apr 26, 2008 3:16 am

Hi Gm!

I don?t see all pink faces, triangles and squares in green.

Need an image?

I've a 8600GT and WinXp32, let me try it in x64...

See you soon. ;D
Genomax
Member
 
Posts: 18
Joined: Wed Apr 23, 2008 4:48 pm
Location: Spain

Postby Ron_Emad2 » Sat Apr 26, 2008 7:31 am

Dear Gm-Support
Yes-I have difficult with beta 1 on geforce 8400
but in new version i dont see any difficult but the screen is pink
and i thinks it can remove fast?
with thanks
emad
Hello
I from iran
i cant speak english correctly
please forgive me
User avatar
Ron_Emad2
Active Member
 
Posts: 85
Joined: Fri Oct 13, 2006 12:08 pm
Location: Iran-Kashan

Postby GM-Support » Sat Apr 26, 2008 9:58 pm

Candle wrote:this is a new card i just got last week
Oh ok, I see. Sorry for the misunderstanding.


Von Knudenberg wrote:F-18C Hornet
Wow!


Von Knudenberg wrote:I had same kind of results like with 1.5 beta. Starting face is okay (with green triangle when turning from right). All the other faces turns to green, just like they did with 1.5.
Ok, thanks for the info. So it seems that it is not a problem of textures or texture coordinates then. Thanks.


Imari wrote: pink and green version (oh my eyes! :shock: :P )
LOL, I used the first colors I found :)


Imari wrote:1. If I place my cursor mid-way down one of the corner seams/edges and drag my cursor straight down, I get a green triangle, pointing left and forming always to the left side, not the right. If I continue dragging down the corner seam until I pan onto the bottom face of the cube, I can still see the triangle on the left "wall" and the floor is divided in half on the diagonal. The left half of the floor is green.
2. If I drag my cursor upwards from the mid-way point on the seam instead of down, the triangle does not form, however, soon after my cursor crosses the corner onto the top face of the cube, the whole top face of the cube goes green.
3. Back to the midpoint of the corner seam... If I pan left, I first get the green triangle pointing left towards the center of the face. Then the face is entirely green for about 20 degrees of movement, and then the pink face "renders".
4. From the midpoint of the face, I can move up or down to the upper and lower edges just fine, but if I pan more than about 20 degrees left or right of center, the whole face goes green again.
Thanks Imari. That sounds pretty complicate, with no simple recognizable pattern... mmmh...


Genomax wrote:I don?t see all pink faces, triangles and squares in green. Need an image?
Thanks Genomax. There is no need an image if it is the same problem that the others are experiencing. Let me know in case you find a simple pattern (i.e. a simple law that determines when the triangles are rendered and when they are not).


Ron_Emad2 wrote:but in new version i dont see any difficult but the screen is pink
Ok. Thanks Emad.
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby GM-Support » Sun Apr 27, 2008 12:15 am

I have attached to this message a small app for testing DirectX 7 (the same version used by the cubic panorama plugin).

When you launch the DirectXTest.exe file, you should see a colored square that rotates at the center of the screen, as shown in the attached screenshot. It runs full screen, so don't be afraid if when you launch it it takes the whole screen (it's like most games).

If the attached test file works fine, I can use it to improve the cubic panorama plugin.

Note: this is only for the people who are experiencing the GeForce problems
Attachments
directx7_test_app_screenshot1.png
What you should see in full screen (the square rotates)
directx7_test_app_screenshot1.png (3.86 KiB) Viewed 8925 times
DirectX7Test.zip
The test application
(3.06 KiB) Downloaded 279 times
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Candle » Sun Apr 27, 2008 12:30 am

Seem to work fine on mine.
Attachments
2008-04-26_182943.jpg
2008-04-26_182943.jpg (7.37 KiB) Viewed 8922 times
Please don't PM me questions, ask here in the forums!
``````````````
Between grand theft and a legal fee, there only stands a law degree.
User avatar
Candle
Administrator
 
Posts: 3055
Joined: Sat Feb 07, 2004 2:21 am
Location: Rudy's Bar

Postby Imari » Sun Apr 27, 2008 2:54 am

The DX7 test worked fine for me. Simple 4 color square, spinning in one plane.
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby Von Knudenberg » Sun Apr 27, 2008 9:30 am

This test worked fine for me too.

-Pete
Von Knudenberg
Member
 
Posts: 54
Joined: Mon Jan 28, 2008 11:20 am
Location: Finland

Postby GM-Support » Sun Apr 27, 2008 1:27 pm

Ok, thanks. I am going to change the plugin so that it has the same settings as the DirectX test.
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Ron_Emad2 » Sun Apr 27, 2008 2:31 pm

Oh :roll:
I thinks new version of this plugin coming soon 8)
i wish this work fine
with thanks
emad
Hello
I from iran
i cant speak english correctly
please forgive me
User avatar
Ron_Emad2
Active Member
 
Posts: 85
Joined: Fri Oct 13, 2006 12:08 pm
Location: Iran-Kashan

Postby Genomax » Sun Apr 27, 2008 7:21 pm

Hi!

test worked fine for me, master.

C.U
Genomax
Member
 
Posts: 18
Joined: Wed Apr 23, 2008 4:48 pm
Location: Spain

Postby Ron_Emad2 » Tue Apr 29, 2008 6:34 am

oh / dear Gm-Support
Please wright about licences of this plug-in for commerical use
in finial version we can use it for commerical ??
with thanks
emad :D
Hello
I from iran
i cant speak english correctly
please forgive me
User avatar
Ron_Emad2
Active Member
 
Posts: 85
Joined: Fri Oct 13, 2006 12:08 pm
Location: Iran-Kashan

Postby GM-Support » Wed Apr 30, 2008 3:16 pm

OK, so here is the beta 1.7.

I have made lots of changes, so I cross my fingers.

What you should see this time is the 6 faces of the cube in black, and the background in green (see attached screenshot). When you launch the game, the whole screen should be black, and, as you turn around, you should see the 6 black faces.

Thanks.
Attachments
panorama_plugion_beta1_7_screenshot1.jpg
Screenshot of the beta 1.7: you should see 6 black faces on a green background
panorama_plugion_beta1_7_screenshot1.jpg (46.9 KiB) Viewed 8804 times
CubicPanoramaPlugin_ID1.ocx.zip
The beta 1.7 of the OCX
(29.02 KiB) Downloaded 286 times
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

PERFECT

Postby Genomax » Wed Apr 30, 2008 9:25 pm

HI GM!

I run the test perfectly, black squares with green edges.
No distorsion, no flicking....

PERFECT!

THanks! :D
Genomax
Member
 
Posts: 18
Joined: Wed Apr 23, 2008 4:48 pm
Location: Spain

Re: PERFECT

Postby GM-Support » Wed Apr 30, 2008 9:31 pm

Genomax wrote:HI GM!

I run the test perfectly, black squares with green edges.
No distorsion, no flicking....

PERFECT!

THanks! :D



Wow, that is really great news!!!

I am going to add the textures back, to see if we can keep it working.
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Imari » Wed Apr 30, 2008 11:12 pm

::jumps up and down!!!::

Whoo-hoo! It works, Giovanni. Yer a genius. :wink:
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby GM-Support » Wed Apr 30, 2008 11:17 pm

:D

Let's try with the textures now (attached is the beta 1.8 ).

I hope it works with the textures too :)
Attachments
CubicPanoramaPlugin_ID1.ocx.zip
The beta 1.8 of the OCX
(30.24 KiB) Downloaded 299 times
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Imari » Wed Apr 30, 2008 11:27 pm

Version 1.8 worked great! You may need to tweak something in the Image Combiner, though. In each "room" of my test, I had a 1 pixel wide, dotted white line along the seam of the upper face of the cube. I have Image Combiner version 1.0.

Great work!
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby GM-Support » Wed Apr 30, 2008 11:30 pm

Imari wrote:Version 1.8 worked great! You may need to tweak something in the Image Combiner, though. In each "room" of my test, I had a 1 pixel wide, dotted white line along the seam of the upper face of the cube. I have Image Combiner version 1.0.

Great work!


Thanks Imari!

Can you please attach your combined image so that I can tweak the texture coordinates?

Thanks
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Imari » Wed Apr 30, 2008 11:40 pm

Hi GM, I was just testing the new plug-in in the new version of AM, so it works in both 4.4 and 4.5. One of my test frames is attached.
Attachments
Pano1.jpg
Pano1.jpg (850.07 KiB) Viewed 8769 times
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby GM-Support » Wed Apr 30, 2008 11:54 pm

Mmm... I cannot seem to reproduce the 1-pixel problem on my computer.

1. Does it concern only the upper face?

2. Do the 4 edges (the 4 lines that form a square around the face) of the upper face look the same? I mean, are they all white, or is one of them of another color?

Thanks
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Perfect!

Postby Genomax » Thu May 01, 2008 12:51 am

Great Master, thanks!!!!!

It work perfect now... only my first problem persist... the small difference of images in the edges...

Attach a litle image.

Thanks you for the support!

C.U

I used the same cubemap...
Attachments
test1.jpg
test1.jpg (238.51 KiB) Viewed 8761 times
Genomax
Member
 
Posts: 18
Joined: Wed Apr 23, 2008 4:48 pm
Location: Spain

Postby Imari » Thu May 01, 2008 1:07 am

Hi GM, yes it only seems to affect the top face. Perhaps it has something to do with the way my computer is reading the upper edge of the composit image? I also see a slight shift between places in one frame, similar to the problem that Geno is having.

Here are two pictures, sorry for the large size. I can reduce them if need be.
Attachments
ceiling.jpg
ceiling.jpg (184.59 KiB) Viewed 8759 times
Last edited by Imari on Thu May 01, 2008 1:08 am, edited 1 time in total.
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby Imari » Thu May 01, 2008 1:07 am

The one with the shift.
Attachments
ceiling2.jpg
ceiling2.jpg (170.86 KiB) Viewed 8757 times
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby GM-Support » Thu May 01, 2008 1:31 am

Imari, can you please attach the combined image that corresponds to the second problem? (the shift)

Thanks
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Imari » Thu May 01, 2008 2:40 am

Sorry... went for dinner... here it is, GM.
Attachments
LagTunnAM.jpg
LagTunnAM.jpg (1.61 MiB) Viewed 8748 times
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

Postby GM-Support » Thu May 01, 2008 4:02 am

Thanks.

The reason why I wasn't able to reproduce your problem is that I was using 2048x1365 images, while you seem to be using 3072x2048 pictures.

I will keep you updated.
GM-Support
Forum Admin and Games Page admin
 
Posts: 2221
Joined: Thu Jun 05, 2003 7:52 pm

Postby Imari » Thu May 01, 2008 4:10 am

Oops, I mistakenly thought that the Image Combiner automatically resized to the proper dimensions. Sorry. :oops:
User avatar
Imari
VIP
 
Posts: 872
Joined: Fri Jun 20, 2003 4:49 pm
Location: Virginia, USA

PreviousNext

Return to Adventure Maker General Discussion

Who is online

Users browsing this forum: No registered users and 11 guests

cron