Another Question about video

This forum is meant for posting anything related to Adventure Maker that doesn't fit in the other forums.Please post technical questions in the Technical Support Forum!

Moderators: time-killer-games, Vengeance66, Candle, reneuend, GM-Support

Another Question about video

Postby PenMasterRule » Tue Jun 23, 2009 5:33 pm

Hi everyone. I have another question about video. When I click the hotspot the video plays fine, but there is a delay from the time the hotspot is clicked to the moment the video starts playing. Is there a way to speed that up some? Maybe have the video play about 2 seconds after the hotspot was clicked?
PenMasterRule
Member
 
Posts: 31
Joined: Thu Jun 18, 2009 8:36 pm

Postby mercedes » Tue Jun 23, 2009 6:12 pm

It might be one of those things..that the more times u click it..the faster it plays..It's at that point -loading the video..[the first time]
Have u tried to click it more than once..say leave the frame..come back and click it again,...and does it load any faster..?
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby PenMasterRule » Tue Jun 23, 2009 6:28 pm

mercedes wrote:It might be one of those things..that the more times u click it..the faster it plays..It's at that point -loading the video..[the first time]
Have u tried to click it more than once..say leave the frame..come back and click it again,...and does it load any faster..?


Nah. I just click it once and after about 10 seconds it starts playing.
PenMasterRule
Member
 
Posts: 31
Joined: Thu Jun 18, 2009 8:36 pm

Postby mercedes » Tue Jun 23, 2009 6:35 pm

How big is the file..u are loading..? and what extension does it have..?
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby CBSection31 » Tue Jun 23, 2009 6:39 pm

In general, the larger the file size of the video you are about to play, the longer it will take to play. This is because the video must first be loaded into memory before it will play back.

Other factors that will affect the speed of this are the computer's RAM, processor speed, and free hard drive space.

Did you compress the video? As mercedes asked, how large is the file?
CBSection31
Code Master
 
Posts: 564
Joined: Tue Jun 10, 2003 4:00 am

Postby Lyberodoggy » Tue Jun 23, 2009 10:07 pm

There's a property of the mpobject, that is called BufferingTime, that unfortunately cannot be set during runtime.
User avatar
Lyberodoggy
Administrator
 
Posts: 2519
Joined: Sat Feb 17, 2007 3:31 pm
Location: Athens

Postby juhuwoorps » Wed Jun 24, 2009 12:55 am

do you try to play the video in the same frame?if not you should try to set the background as the first frame of your video!
i had the same problem with full screen animations and this works for me.
juhuwoorps
Code Master
 
Posts: 622
Joined: Tue Jul 08, 2008 3:13 pm

Postby mercedes » Wed Jun 24, 2009 3:48 am

juhuwoorps wrote:do you try to play the video in the same frame?if not you should try to set the background as the first frame of your video!
i had the same problem with full screen animations and this works for me.


Hey Juhu..:)

I do that too for animations..this way u get a seamless animation when it plays....and no jumping from the first layer to the rest of the animation..and it seems to play quicker too..:D~
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~


Return to Adventure Maker General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron