Add Item..?

This forum is meant for requesting technical support or reporting bugs.

Moderators: time-killer-games, Vengeance66, Candle, reneuend, GM-Support

Add Item..?

Postby mercedes » Wed Jul 30, 2008 7:54 am

Hi there


for some reason..AM will not allow me to start my game with the magnifier in the inventory...

Code: Select all
Action.AddItem "Magnifier2"


I have that code in the frame properties..I have tried it in the Frame Properties..in the Project properties..I don't know..:?

AT first I thought it was because I had put a picture .gif file where the inventory would appear..was just trying something out..Then I took it away..Still not allowing me to put it..

Then i tried another inventory item..which was an APPLE.. then it let me..so i put the picture back where inventory would be and added the apple anyways..and it still worked..so its not the picture...gif file..Nor any other inventory items..just this silly magnifier..lol

Any ideas?


Many Thanks!!~
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby Mystery » Wed Jul 30, 2008 10:20 am

There must be a little mistake somewhere with the magnifier...

Have you added the image of the magnifier as inventory item? Is it called Magnifier2?
User avatar
Mystery
Forum Admin and Games Page admin
 
Posts: 2990
Joined: Sat Feb 04, 2006 8:12 am
Location: Switzerland

Postby mercedes » Wed Jul 30, 2008 11:30 pm

Hi there...:)

That problem fixed itself..It was in my inventory..but for some reason.It wouldn't work..but it is now..:? Perhaps i spelled it wrong..i'm not sure..

Thanks!~


I wanted it to appear automatically when the game starts..so I had put that code in the Starting Frame..

Should I put it there or in the Projects properties..under advanced with the option to load it when game is saved or loaded..? or both




Many thanks!
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby Lyberodoggy » Fri Aug 01, 2008 10:13 am

no, just the starting code. Else it will be loaded again and again.
User avatar
Lyberodoggy
Administrator
 
Posts: 2519
Joined: Sat Feb 17, 2007 3:31 pm
Location: Athens

Postby mercedes » Fri Aug 01, 2008 9:36 pm

Hey..
Sorry...Do you mean the starting Frame..Lyberodoggy..?

..



Thanks for response..:)


Peace~
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby Lyberodoggy » Sat Aug 02, 2008 7:01 pm

I mean the first frame of the game :P
User avatar
Lyberodoggy
Administrator
 
Posts: 2519
Joined: Sat Feb 17, 2007 3:31 pm
Location: Athens

Postby mercedes » Thu Aug 07, 2008 7:55 am

This isn't working for some reason


When i add item to project start up..in the Advanced tab..Under the first option...when i test the frame..or Run the Project it tells me that the item is not available..if i add it to the Frame that first starts..it works..Only everytime i visit the frame..it uploads the item again..So if i visit the same frame 3 times..I end up with 3 magnifying glasses..?? If i put it in the second option of the Advanced on start up..it makes i so every frame uploads the item again and again..

Any Ideas..thanks





Peace
Adieux
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~

Postby Mystery » Thu Aug 07, 2008 11:08 am

If the player can visit the first frame more than once, work with variables, and create a variable for that item.

Add to the first frame of your game something like
Code: Select all
If Item = 0 Then
  Action.AddItem "Item_Name"
  Item = 1
End If
User avatar
Mystery
Forum Admin and Games Page admin
 
Posts: 2990
Joined: Sat Feb 04, 2006 8:12 am
Location: Switzerland

Postby mercedes » Thu Aug 07, 2008 8:46 pm

That works.. Thank You!~

Never occured to me that i would have to use a variable..lol..Seems to me I've done this before..and didn't make a variable..Oh well..it works..~




Peace~
User avatar
mercedes
VIP
 
Posts: 2460
Joined: Sun Mar 09, 2008 10:43 pm
Location: Canada..~


Return to Adventure Maker Technical Support and Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests

cron