Problem with Keyguard plugin

This forum is meant for announcing new plugins, downloading other people's plugins, posting questions, etc.

Moderators: time-killer-games, Vengeance66, Candle, reneuend, GM-Support

Problem with Keyguard plugin

Postby drummerac » Fri Apr 10, 2009 5:11 pm

I am trying to design an educational tool with adventure maker and I need text to pop up when the mouse hovers over a hotspot.

I downloaded and installed version 4 of Keyguard and enabled the plugin in "project properties", but it doesnt appear in the plugins area of the frame properties.

I am using version Adventure maker v4.5.2

Does anyone know the solution to this problem?
User avatar
drummerac
Member
 
Posts: 53
Joined: Fri Apr 10, 2009 5:07 pm
Location: Ireland

Postby reneuend » Fri Apr 10, 2009 6:29 pm

Please review the documentation. It's not the type of plugin that shows up in the plugin tab. Instead, it runs behind the scenes.

You'll be adding lines of code in the "advanced" tab and using the "procedures" button from the advanced tab to build what you need. It's easier then it sounds.

You can also load and review the demo for keyguard. I find this to be very helpful with a new plugin!

Post back if you have problems getting it to work for you. :wink:
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA

Postby drummerac » Sat Apr 25, 2009 5:02 pm

Thanks for your reply reneuend,

unfortunately i dont understand the instructions for the keyguard plugin.

Can someone post some sample code so at least I can see where how the code fits together?

I only need to define the location of the hostspots and text that appears when the pointer hovers over the hotspot.
User avatar
drummerac
Member
 
Posts: 53
Joined: Fri Apr 10, 2009 5:07 pm
Location: Ireland

Postby reneuend » Sat Apr 25, 2009 6:03 pm

I'm going to build a step-by-step tutorial on using KeyGuard for the next AM Magazine. As I plan on doing a series of them, I'll start with a simple example.

As soon as I finish it, I'll send you a copy! :wink:
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA

Postby drummerac » Sat Apr 25, 2009 6:23 pm

Thanks for your fast reply reneuend,

thankfully i figured out keyguard just a few minutes ago. The instructions dont explain that you need to code each frame as well as the project properties itself.

I now have a new problem:

if i create the hotposts in AM, then each frame will have identitcal numbered hotspots (the first hotspot in each frame is always number 1).

Each hotspot is now visible on all frames :(

Does anyone know a solution to this?
User avatar
drummerac
Member
 
Posts: 53
Joined: Fri Apr 10, 2009 5:07 pm
Location: Ireland

Postby reneuend » Sat Apr 25, 2009 11:21 pm

Each frame's hotspots are unique from another frame. So even though they have the same index, it is not the same hotspot.

Are you getting errors? :?
If so, I think we'll need to see the code.

(Edit): I just thought of something. Be sure the first command for EACH frame - Advanced Properties clears the hotspots:

Code: Select all
Component("KeyGuard").Object.ClearHotSpots
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA


Return to The Plugins Corner

Who is online

Users browsing this forum: No registered users and 1 guest

cron