Animated gif problem.

This forum is meant for requesting technical support or reporting bugs.

Moderators: time-killer-games, Vengeance66, Candle, reneuend, GM-Support

Animated gif problem.

Postby Paul.S » Tue Jun 07, 2016 8:18 pm

I looked all through the forums and couldn't find an answer so I'll ask :) I'm at the stage of adding in the animated gifs into my game but I'm having a problem. Whenever I go to a screen which includes an animated gif (in game) the first frame of the gif that shows is always black, and then it plays normally. There is a maximum of 2 animated gifs on screen at a time. I haven't used avi for video instead of animated gif because the avi videos I have been able to make are of too poor a quality to go into a finished game. The animated gifs are played as a loop.
Paul.S
Member
 
Posts: 23
Joined: Thu Nov 26, 2015 8:53 pm

Re: Animated gif problem.

Postby reneuend » Tue Jun 07, 2016 10:13 pm

Hi Paul,

I'm on the case. I'll do some testing and see what I can find.
[UPDATE] I didn't have any issues with my testing. I had a start up frame that when I clicked on a hotspot, it opened another frame with 3 animated gifs of varying sizes and speeds. The frame opened to the gifs which played immediately without flicker, static, or black.

I would suggest testing a professional gif from the internet (one that you can rely on as high quality), and see if it starts differently. It could be the tool you are using to build the animated gif.

report back!
Last edited by reneuend on Tue Jun 07, 2016 10:24 pm, edited 1 time in total.
Reason: update
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA

Re: Animated gif problem.

Postby Paul.S » Thu Jun 09, 2016 1:49 pm

Hi reneuend,

I got a high quality gif online but the same proble still occurred. I've been having so many problems with AM lately. Maybe it's because of using windows 10. Is there any news on an update to AM? It's been a while since the last one.

As an alternative to using animated gifs I could use avi videos, but I have so far not been able to find any way of converting from mp4 to avi and retaining any sort of quality of image. If you have any sort of suggestions along this route I would be very happy to hear.

thanks

paul
Paul.S
Member
 
Posts: 23
Joined: Thu Nov 26, 2015 8:53 pm

Re: Animated gif problem.

Postby reneuend » Sat Jun 11, 2016 6:56 am

I would suggest using the MP4 files and don't convert.
Download the codec package, KLIte from here ---> http://codecguide.com/download_kl.htm
Install on your own machine and then include the install file during compile time so others can include it.
I'm using this for my large projects where I have a lot of animations.
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA

Re: Animated gif problem.

Postby Paul.S » Mon Jun 20, 2016 2:37 pm

I didn't know I could use MP4 files. That's some useful information I shall give it a go. In the meantime, I can avoid the issues with animated gifs by using the gif sequence player instead, that doesn't seen to have any issues with transitions or black frames or anything. I'll use this for my demo and shall experiment with using MP4 videos for the next game :) As always, thank you for the help!
Paul.S
Member
 
Posts: 23
Joined: Thu Nov 26, 2015 8:53 pm

Re: Animated gif problem.

Postby reneuend » Thu Jun 23, 2016 11:16 am

Please let us know how it works out for you!
---


Image
Image
User avatar
reneuend
Administrator
 
Posts: 2691
Joined: Sat Nov 22, 2008 8:37 pm
Location: Midwest Cornfield, USA

Re: Animated gif problem.

Postby domozo » Fri Jun 24, 2016 10:59 pm

Good luck :)
User avatar
domozo
Frequent Poster
 
Posts: 147
Joined: Mon Jan 24, 2011 9:40 pm
Location: Syria-Latakia


Return to Adventure Maker Technical Support and Bug Reports

Who is online

Users browsing this forum: No registered users and 0 guests

cron